2 posts
0
new
Go to last post
Active-X control for Tekla Web Viewer
16.07.2017 13:52

Dear all,
I used IE 11 on window 10 operation for opening a Tekla model as Web viewer. But IE prompt Error: Webviewer active-x control could not be loaded. I also do some guides from Microsoft to enable active-x control but still cannot open this file. I try to open another model and it has the same problem.
Pls help me to resolve with many thank.

No Upvotes
To fix this, you can manually
Re: Active-X control for Tekla Web Viewer 18.07.2017 14:26

To fix this, you can manually register the necessary files.
First, create a new folder on the C:\ drive. This must be a permanent folder, since the file locations will be remembered by Windows.
In this new folder, place the following files:
* A copy of the msvcr71.dll file from the …Tekla Structures\\nt\bin folder
* A copy of the regsvr32.exe file from the C:\Windows\system32 folder
* A copy of the zkitlib.dll file from a webviewer model’s “dll” folder.
Now open a command prompt and navigate to your new folder.
Type regsvr32 zkitlib.dll and Enter to register the dll file.
Finally, reopen a Tekla Structures Webviewer model.

Please note that this setting may be managed by your system administrator and may be restricted.

7 Upvotes