24 posts
0
new
Go to last post
Loading Time everytime I click a button
24.02.2014 12:41

Evening All,

Everytime I run a command/click a button, the loading wheel (on wheel on windows 7) pops up and rotates for a few seconds. For example, clicking on concrete slab or creating a steel beam or opening the component dialogue box, causes the loading icon to show for a few seconds and then the command runs without any problems.

I'm pretty sure its not my computer being slow, given that the specs are:
16 GB Ram
220 GB SSD (Where tekla & windows are installed)
Geforce GTX 670
i5-3570 CPU @ 3.4 GHz

Any ideas ?

No Upvotes
Definitely not a pc
Re: Loading Time everytime I click a button 24.02.2014 20:05

Definitely not a pc performance problem, i'm working with ~5 years old pc without any problem. Admins should solve this. Good luck.

No Upvotes
Thanks for providing
Re: Loading Time everytime I click a button 26.02.2014 12:55

Thanks for providing information on your system setup, this always helps when trying to solve a performance issue. Based on them, your laptop setup should be good to run Tekla Structures Learning in terms of operating system, memory and processor. Rendering in Tekla Structures uses OpenGL technology, so graphics cards with good hardware support for OpenGL give the best performance. Up-to-date display drivers are very important, so you please check that you have the latest driver installed - this might solve your problems. 

To compare your setup further to the recommendations, please refer to the following documents:
Technical sheet on Tekla Structures Learning: http://campus.tekla.com/tekla-structures-learning-technical-product-sheet 
A more comprehensive hardware recommendation: http://teklastructures.support.tekla.com/en/support-articles/tekla-structures-191-hardware-recommendation

There have been also some cases where a 3rd party software has hooked to Tekla Structures. This means that the other software grabs into Tekla Structures code and prevents Tekla Structures from operating correctly. You could check this article to see if another software in use could be causing the problems: http://teklastructures.support.tekla.com/en/other-software-hooking-tekla-structures 

Hope this helps!

No Upvotes
Based on the recommendations,
Re: Thanks for providing 27.02.2014 09:34

Based on the recommendations, the only thing I'm lacking is in the OS department - I'm running win 7 64 bit.

With regards to the AppInit - there was nothing in the list.

This loading time is slowly driving me nuts. It does this to every single command.

No Upvotes
I have massively narrowed
Re: Based on the recommendations, 03.03.2014 10:55

I have massively narrowed down the issue:

If I disconnect the internet connection and use Tekla, the loading 'issue' completely disappears; similarly, if I reconnect the internet and use Tekla, the loading 'issue' returns.

1 Upvote
Thank you for this
Re: I have massively narrowed 05.03.2014 09:34

Thank you for this information! We will investigate why the internet connection has this effect to the software usage. 

No Upvotes
My feeling is that the
Re: Thank you for this 06.03.2014 03:01

My feeling is that the software pings the tekla learning license server when you run a command. This isn't problematic if your in america, but if your living further away, say in australia, then the ping time is noticeable.

No Upvotes
I've noticed it also depends
Re: My feeling is that the 22.03.2014 16:33

I've noticed it also depends on the size of your model. If I have a very large model, the loading wheels during commands are frequent, if I have a smaller one, they're not as frequent. Maybe it's trying to get parameters for the part you're working on from the database, and that's where the loading wheel appears.

No Upvotes
I'm sure that is true, but my
Re: I've noticed it also depends 23.03.2014 10:16

I'm sure that is true, but my issue is purely because of the software pinging the tekla server.

No Upvotes
Tekla freezes in every command
Re: I'm sure that is true, but my 25.03.2014 19:16

Yep, you´re right. I managed to replicate your problem and solution on my copy of Tekla. All of a sudden it starts freezing every time I try to do something. As soon as I unplug the internet connection, it's a speeding bullet once more, with no wait time.

No Upvotes
The program only needs to
Re: Tekla freezes in every command 28.03.2014 02:44

The program only needs to ping the server when logging in, and maybe at 1 hour intervals, but not for every command.

No Upvotes
We have just released a new
Re: The program only needs to 16.05.2014 14:53

We have just released a new version of Tekla Structures Learning and it is available in the Download section. The issue described in this thread has been fixed in the new version - please update to gain the fix!

2 Upvotes
Thank you. Please pass along
Re: We have just released a new 25.05.2014 06:50

Thank you. Please pass along my thanks to the coding team as well.

No Upvotes
I am still facing this issue
Re: We have just released a new 06.12.2017 21:43

I am still facing this issue in 2017i Tekla Structures Learning. It looks like each major command is pinging the server and it just clogs up TS.

No Upvotes
Thank you for reporting this
Re: I am still facing this issue 19.12.2017 16:03

Thank you for reporting this issue. We are working on identifying the root cause of it.

Sorry for the inconvenience.

No Upvotes
Still facing this issue
Re: Thank you for reporting this 20.04.2018 15:13

It has been a while now, this bug is growing teeth.
Any news?

No Upvotes
The user has deleted this message
Re: Still facing this issue 23.04.2018 17:25

The user has deleted this message

Would also appreciate a
Re: Still facing this issue 23.04.2018 17:27

Would also appreciate a response on this. Struggling to get by at the moment with the speed of tekla

No Upvotes
Speeding Tekla up
Re: Would also appreciate a 27.04.2018 00:44

Tekla speeds up after you disconnect from the internet. You need to tick the "say connected" box when logging in.
Also, you need to reconnect every hour or so. So yeah, that's a bit bothersome.

No Upvotes
The user has deleted this message
Re: Speeding Tekla up 11.05.2018 18:02

The user has deleted this message

This problem has been
Re: Would also appreciate a 12.05.2018 20:54

This problem has been reported over 5 months ago now. This problem should have been obvious with even the basic testing, as it makes the software virtually useless. On top of that, the probleem seems not to be taken seriously.
Very disappointing.

No Upvotes
Hi, we take this problem
Re: This problem has been 17.05.2018 08:21

Hi, we take this problem seriously and are working on fixing it. We are sorry for the inconvenience.

No Upvotes
Any update?
Re: Hi, we take this problem 18.05.2018 16:51

Any update?

No Upvotes
Status?
Re: Any update? 01.06.2018 12:17

Since you have been working on it for six months now, surely some progress was made.

No Upvotes